Issue affecting e-mail

Incident Report for University of Essex IT

Monitoring

The issue affecting our e-mail service has been identified and mitigated. E-mails are now sending and delivering at normal speed. We are continuing to monitor the service closely to ensure stability and performance remain consistent.
Thank you for your patience while we resolved this issue.
Posted Nov 03, 2025 - 10:14 GMT

Update

We are continuing to investigate this issue. E-mails are sending, but the service is still running more slowly than usual.
Posted Oct 30, 2025 - 11:39 GMT

Investigating

We're aware of an issue affecting our e-mail service - causing e-mails to be delivered more slowly than usual - and are currently investigating.

Sorry for any inconvenience this may be causing you. We'll post another update as soon as we know more.
Posted Oct 29, 2025 - 16:20 GMT
This incident affects: Email.